Jump to content
Sign in to follow this  
Stuart Duncan

ES Latest Beta error messages

Recommended Posts

Stuart Duncan

Hi all,  

I upgraded from Beta 16 to Beta 17.

Now when I launch ES, I get the following error messages:

Error: DISPLAY line needs 3 params in line 5498
Error: DISPLAY line needs 3 params in line 5597

These are the only two error messages I get, ES still runs stable, and when I go back to Beta 16, I have no error messages.  Something must have changed in the latest beta.

I initially raised this on the .net forum and it was suggested this was a SCT issue, not an ES issue.  As I stated on the .net forum, the syntax of these lines is identical to the lines above and below.

On looking at the ESE, line 5498 is

DISPLAY:Scottish AC East:Only PDAPP

and line 5597 is

DISPLAY:Central:Only PFAPP

 

Following the syntax of the code above the lines in question, which do appear to have three parameters, I was able to resolve the error messages at startup by making the following changes:

DISPLAY:Scottish AC East:Scottish AC East:Only PDAPP
DISPLAY:Central:Central:Only PFAPP

I just wanted to make the UK Sectorfile developers aware, but also ask, will the changes I've made break something else?

Cheers,

Stu

 

 

 

Edited by Stuart Duncan

Share this post


Link to post
Share on other sites
Harry Sugden

I've popped these in github. Though, these error messages should've still appeared with previous versions of EuroScope, since they don't relate to anything new introduced in this beta!

Your amendments make the lines as they should be.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×