Jump to content

[TRIAL] VATATIS - New ATIS Generation System


Luke Brown
 Share

Recommended Posts

Our current method of generating ATIS's, courtesy of UniATIS has been around as long as I've been on VATSIM (for those that don't know me, that's quite a long time) And yes, I know that's not as long as @Chris Pawley has been here. Recently, we've been having a few issues with UniATIS falling over, it being somewhat abandoned and it's difficult to see any further new features being added. Luckily we have a solution.

Introducing VATATIS...

VATATIS is designed to be a modernised replacement of the UniATIS site, offering some improvements in customisability, automation and day to day ease of use

The standout features for me so far:

  • ATIS letters harmonised server side, so everyone is on the same letter, always.
  • Automatic detection of top down controllers, i.e. automating "for start clearance call 123.456"

These are only a couple of things that I've noticed so far, but we as a division have the oppourtunity to work with Alex (VATATIS developer) to make it do what we want.

So, here comes the part where we're asking for help. As an intial test we will be asking controllers who want to participate to use the VATATIS system at three trial airfields:

  • EGSS (Stansted)
  • EGPH (Edinburgh)
  • EGGD (Bristol)

Simply replace your ATISmaker url in EuroScope withe the one provided by VATATIS. That's it. Then all we ask is that you provide feedback on where the system is either providing weird responses, malformed ATIS's or something just doesn't look right.

More details on the system can be found on our VATATIS test site if you're too lazy to even find your way there and read the documentation, the url you need to use is:
https://uktest.vatatis.nz/gen?apptype=ILS&arr=$arrrwy($atisairport)&dep=$deprwy($atisairport)&metar=$metar($atisairport)

Once you get it to generate, note the letter in the big white box in the ES dialog, and match your ATIS letter to it. The letter will be the same for everyone as it's handled by VATATIS.

NOTE: Whilst the test site has a login button, it will not work, and serves no purpose (yet)

Providing feedback

To give feedback on the sytem, either reply to this topic with screenshots of your ES ATIS dialog so we can see what has gone wrong or join the VATATIS discord.

Look forward to hearing what you think!

Cheers,
Luke

Edited by Luke Brown
Link to comment
Share on other sites

Thomas Mills

Couples of notes/ tips from me (will update as I mess about):

  • Currently there may / may not be an issue with VATATIS returning the wrong airport after an ATIS change, this seems to be fixed by just clicking 'Test URL' again - worth double checking after a change, let us/ VATATIS know if you notice this behaviour.
  • VATATIS detects which position is logged on but doesn't seem to do this very often - if a position comes on/ disconnects below you, wait a minute for the data to update, then click 'Test URL' and it should update - this is because while VATATIS polls the controller data every minute, ES only requests a new ATIS on metar change, and would take till then to do it automatically
  • The ES ATIS letter should update with but doesn't always seem to do this, keep an eye and let us/ VATATIS know when you experience this - this might be related to an issue with VATATIS seeming to 'skip' ATIS letters

 

Edited by Thomas Mills
Link to comment
Share on other sites

David Waterman

Just a quick one the above link didn't work at EGPH. I grabbed it fresh from the VATATIS website and that worked

Link to comment
Share on other sites

Luke,

Fantastic Work.... As I am in the mood for a bit more ATIS Bot work please get in contact if you want any changes on the AFV Text to voice ATIS server let me know.  We did a lot of work with the Scandies earlier in the year but if you need anything just shout.

Cheers

G

  • Like 1
Link to comment
Share on other sites

Edward Berkley

Hi all, was testing the atis at EGGD and noticed that it was giving the incorrect departure frequency.

image.png.4a34b92e1f30e147bbc1a9cfb037a5ed.png

Link to comment
Share on other sites

Edward Berkley

 

5 hours ago, Edward Berkley said:

Hi all, was testing the atis at EGGD and noticed that it was giving the incorrect departure frequency.

image.png.4a34b92e1f30e147bbc1a9cfb037a5ed.png

Nevermind, it seems to have fixed itself

Edited by Edward Berkley
Link to comment
Share on other sites

Gail Bartlett

Not sure that it's generating the right transition level at EGSS. With a QNH of 1008, my understanding (and the crib sheet's understanding) is that it should be FL75, not FL65.
image.png.595c1e04e4818ce998c60578a26b561e.png
 

Link to comment
Share on other sites

Just nit-picking based on what I have seen but there’s no need to report the surface condition when it is dry x 3 and where does it get the runway state from just out of interest?

It should report visibilities more than 5000 metres as kilometres i.e. 6 kilometres, 7 kilometres etc.

I would have to see it decipher more complex METARs to see whether it stands up as a valid replacement of UniATIS because I put a lot of effort in coding the UniATIS UK specific settings to output the correct weather from all possible METAR codes.

Link to comment
Share on other sites

Thomas Mills
22 minutes ago, Callum Presley said:

Just nit-picking based on what I have seen but there’s no need to report the surface condition when it is dry x 3 and where does it get the runway state from just out of interest?

It should report visibilities more than 5000 metres as kilometres i.e. 6 kilometres, 7 kilometres etc.

I would have to see it decipher more complex METARs to see whether it stands up as a valid replacement of UniATIS because I put a lot of effort in coding the UniATIS UK specific settings to output the correct weather from all possible METAR codes.

I've passed your feedback along to the VATATIS dev. Do you remember any other METAR quirks that might be worth mentioning? Ofc keen to get this as realistic as possible.

Link to comment
Share on other sites

2 minutes ago, Thomas Mills said:

I've passed your feedback along to the VATATIS dev. Do you remember any other METAR quirks that might be worth mentioning? Ofc keen to get this as realistic as possible.

Off the top of my head:

• had to code it to report cloud below 100ft correctly e.g. BKN000 as broken below 100ft.
• I had to code vicinity weather like VCFG to say Fog in the vicinity rather than in the vicinity Fog.
• TSRA thunderstorm with moderate rain rather than just thunderstorm rain etc
• AUTO METAR decoding for CB detected or TCU detected. 

• I coded it to say hectopascals if it was <1000. 
• There were various glitches that had to be corrected like if it was temperature M00 it would just say zero so that had to be coded to say minus zero. Or if an item was missing from the METAR like 12/// it would say temperature 12 dew point . Instead of just not saying dew point.

• The military METARs needed a lot of custom coding to correctly decode the current colour state and also custom parameters for the military ATIS.

Link to comment
Share on other sites

Thomas Mills
11 hours ago, Callum Presley said:

Off the top of my head:

• had to code it to report cloud below 100ft correctly e.g. BKN000 as broken below 100ft.
• I had to code vicinity weather like VCFG to say Fog in the vicinity rather than in the vicinity Fog.
• TSRA thunderstorm with moderate rain rather than just thunderstorm rain etc
• AUTO METAR decoding for CB detected or TCU detected. 

• I coded it to say hectopascals if it was <1000. 
• There were various glitches that had to be corrected like if it was temperature M00 it would just say zero so that had to be coded to say minus zero. Or if an item was missing from the METAR like 12/// it would say temperature 12 dew point . Instead of just not saying dew point.

• The military METARs needed a lot of custom coding to correctly decode the current colour state and also custom parameters for the military ATIS.

Thanks Callum, I've passed that along - any more feedback absolutely welcome.

Link to comment
Share on other sites

Dean Gibbs

Fair chance this is me setting it up wrong, but on EGSS last night I noticed that the information letter in Euroscope didn't keep track with the changes. I set it to the letter provided when I first generated it (A), when it updated Euroscope set it to B automatically, but when I checked again on the vatatis site it was showing as D. I assume this is because other stations were online and new METARs were generating for them in the meantime. I checked the vatatis site each time it updated and just manually set which letter to display each time but was a bit of a faff.

Edited by Dean Gibbs
Link to comment
Share on other sites

  • 2 weeks later...

Have tried to connect Vatatis at Bristol today and get this (attached). Also, when I click on the link to the Vatatis Discord, it says the invite has expired.

 

Bristol Vatatis test 14-8-2021.jpg

Link to comment
Share on other sites

Have just tried it at Bristol again and it appears ok. Just waiting to see i aircraft can pick it up !

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Similar Content

    • Janet Kino
      By Janet Kino
      In trying to figure out what is current Vatsim UK ATIS practice, I have found:
      a page in the ATC Training Blog that doesn't look terribly out of date, although all of the many images in it seem to have been eaten by the/a Bit Monster.  Euroscope ATIS dialogue box may have changed a little(?) since it was written, but I think it is mostly correct. Several References to a Vatsim.net policy that seems to have been deprecated while no one here is looking, and there doesn't appear to be any replacement.  I have notified the training people here about the dead link(s). An interesting post about new test ATIS setup procedures for for EGPH, EGSS and EGGD, which seems to work fine for EGPH anyway. Not a whole lot of anything that directly relates to Audio for Vatsim and ATIS, except that I shouldn't really worry about voice ATIS, since it mostly isn't working at the moment (due to a lack of voice bandwidth or the network?). Have  I missed anything?  Something?  😜
       
      Edited to wonder... have I posted this in the wrong section?  If so, anyone around that can move it for me?
    • Neville Munro
      By Neville Munro
      Cannot set up a Voice ATIS. UNIATIS returns;
       
      No answer from http://uniatis.net/atis.php?arr=02&dep=02&apptype=ILS&info=A&metar=EGKA 171120Z 35009KT 7000 BKN008 20/18 Q1010
       
      Have I missed something? Advice please.
       
      Neville
    • Daniel Turner
      By Daniel Turner
      Howdy guys, 
      Hoping some of you eurosocpe badgers are able to help me out with my ATIS recording. I recently updated to the newest version of Euroscope, its been quite some time since I updated. Now for some reason I'm unable to add in what runways are in use and I'm constantly getting asked on frequency. It never comes up in my automatically generated atis from the URL and I'm unable to generate a custom one as all the tutorials that I can find seem to point towards an Atis Descriptor for which I have no options when I click on the Letter for the Atis.
      Please see my attached, I'm probably missing something stupidly easy and it's driving me insane!!!
      Thanks for any help anyone can provide!
      Kind regards
      Dan

    • James Allinson
      By James Allinson
      Hi all. 
      I’ve done a search and couldn’t find any similar topics so apologies if this is a duplicate issue.
      I’m using vPilot 2.8.1 with FS2020 and for about 90% of the time in the last month I’ve not been able to hear any ATIS broadcasts at all. I can still get them via text. 
      The voice ATIS is one the the neatest features of VatSim and it’s a shame I can’t get them consistently (well, at all). A controller mentioned ‘there had been issues with it’. Is this a known bug, or do I have an issue somewhere?
      Many thanks
       
    • Dylan Osolian
      By Dylan Osolian
      Hello
      Last week I reinstalled my computer and since then I have had a problem with setting up my voice ATIS on euroscope. I set it up as usual and I can hear it when I press listen playback, but then it doesnt work on frequency. In fact I cant even listen to the frequency. The text ATIS still works as usual. Here is a picture of my voice setup etc.

×
×
  • Create New...