Jump to content
Jack Limb

Joystick Calibrated - Still banking right with GA only

Recommended Posts

Jack Limb

Hello people,

I have attached some pictures to help explain the problem. My problem being, with aileron trim centered, my joystick calibrated and even the null zones all the same for elevation, throttle and rudder and they are all working fine, when i send my joystick to the centre so its fixed without me even touching it, my plane banks to the right and it is so annoying. 

Picture 1= I'm having to apply a small amount of left aileron myself to keep the wings level (which is fine, you probs have to do this in real life to compensate for wind)

http://prntscr.com/lkb5fl

Picture 2= I let go of the joystick and the aircraft (PA28 Just Flight) just banks to the right, quite steeply, all by itself (and the yoke is in the middle!)

http://prntscr.com/lkb5s8


Picture 3= Eventually, it crashes if I don't turn left

http://prntscr.com/lkb63a

Please help! I really need to get this sorted for any chance of completing the P2 course and flying normal GA.

Jack Limb (P3D V4.3)

 

 

 

Edited by Jack Limb

Share this post


Link to post
Share on other sites
Harry Cameron

I would assume it's a bug with the aircraft seeing as the yoke is centered yet the aircraft is banking right, I would recommend contacting JustFlight support and see what they have to say

Share this post


Link to post
Share on other sites
Simon Kelsey

As a test -- what happens if you set the aircraft up on autopilot in straight and level flight, unplug completely all your flight controls, and then disengage the autopilot?

That would confirm whether the issue is coming from your controls or the aircraft itself.

Share this post


Link to post
Share on other sites
Harry Cameron
1 minute ago, Simon Kelsey said:

As a test -- what happens if you set the aircraft up on autopilot in straight and level flight, unplug completely all your flight controls, and then disengage the autopilot?

That would confirm whether the issue is coming from your controls or the aircraft itself.

Either that or fly with the good old mouse yoke 😉

Share this post


Link to post
Share on other sites
Jack Limb
2 minutes ago, Simon Kelsey said:

As a test -- what happens if you set the aircraft up on autopilot in straight and level flight, unplug completely all your flight controls, and then disengage the autopilot?

That would confirm whether the issue is coming from your controls or the aircraft itself.

I'll try again in 45 minutes 🙂 And give an update 🙂

Share this post


Link to post
Share on other sites
Jack Limb

@Simon Kelsey 

So I put autoflight on, stable heading and altitude, unplugged my joystick, took autopilot off and it banked on its own.

But it banked left this time not right. Both situations were at Liverpool, and the wind hadn't changed much, a knot or two.

 

I'm so confused, and its really annoying. I cannot hand fly it properly. I have filed a ticket to Just Flight support too.

Edited by Jack Limb

Share this post


Link to post
Share on other sites
Richard Keen

Are you switching Tanks every 15-20 mins  (i think it is) ? with the JF Arrow you need to switch tanks every so often but you can set this up to happen automatic in the options .

Edited by Richard Keen

Share this post


Link to post
Share on other sites
Richard Keen

Also i see you are using Active Sky  , the JF PA28 (to me anyway) is a bit sensitive to Turbulance .. turn it down to about 20-30 , that might help too

Edited by Richard Keen

Share this post


Link to post
Share on other sites
Jack Limb

Thanks very much Richard!

I’ll try that in my next p2 session.

Switching tanks is cool. I use the right hand side of the clock for the right tank and the left hand side of a clock for the left tank as a guidance 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Similar Content

    • Jacob Gear
      By Jacob Gear
      Hello all, 
      Not sure if this is in the right place so point me in the right direction if not please.
      After a while of not controlling I have tried to install Euroscope, however when loading up I am greeted with a weird issue that no matter what I try will not seem to go away. I have attached a screenshot below. When I try and click the "OPEN SCT" or other menus like settings a green thin line appears all down the page, and there is a grey box that is flickering in and out at the bottom of the client. This is regardless of what Sector file I am using. 
      Info: 
      - I can open the connection menu fine 
      - I have tried uninstalling totally and deleting any files leftover, I have ensured I am running as administrator, I have tried changing display settings on both of my monitors, I have tried using Euroscope in fullscreen and not,. 
      - I am running Windows 8.
       
      Thanks!  

    • Phil Caxton
      By Phil Caxton
      Hi Guys I am very new to all this so having a bit of trouble with XSquawkBox I have down loaded it and unzipped it I believe but there does not seem to be 
      and Exe File there . so how do I install it . I am on Windows 10 and My fight Sim is X Plain 11
      Any help would be greatly received.
      Regards Phil Caxton
       
    • James Taylor
      By James Taylor
      Hi, any help would be gladly appreciated.
      I would like to know what the difference is between a .asr file format and .prf. Inside of the uk controller pack and when I go to "open sct" and "open", all of the .prf files are invisible as it says I need .asr files. Am I doing anything completely wrong or should I just be doing something slightly different?
      Thanks.
×
×
  • Create New...